Page 1 of 5 123 ... LastLast
Results 1 to 10 of 46
  1. #1
    Join Date
    May 2020
    Location
    Nashville
    Posts
    229

    Default Got a leak 2018 Moomba Mojo

    Team,

    I have developed a leak. I had a bad shaft seal and it has been replaced and rechecked. It is working as intended and is the glide drip-less. I can confirm this isn't the leak. I assume its a ballast fitting or my hard tank. I've checked all the ballast fitting I have access to without taking the floor up and haven't found the leak yet. Are there and where are the ballast fittings I need to check that are under the floor or hard to get to. that is my next option to look. Is there some other place to look. I've checked all the thru-hull fittings and this isn't an issue either.

    Thanks for any advice.

    Jason
    2018 Moomba MOJO
    4100lbs. ENZO's, Center Tank, IBS
    780lbs. Lead Wake
    Raptor 400
    Surf Prop: OJ 945
    2019 Ford F150 FX4
    5.0L V8

  2. #2
    Join Date
    Mar 2021
    Location
    South Georgia
    Posts
    1,980

    Default

    I guess you checked your center plug? Also the ballast pump for the front bag should be right there close by that access hatch too. How fast does your leak show up? If you run the boat without using any of the ballast pumps does it still leak? That may help narrow some things down if it does not leak. Then maybe run one pump, or set of pumps, at the time to see when water shows up. Also, do you have a heater? Check all those hose connections if so.

    Sent from my SM-G781V using Tapatalk
    Last edited by HFarr; 06-13-2023 at 02:00 PM.
    2021 Moomba Makai
    Black Cherry Metal Flake & Fire Red
    Nibral OJ 15.5x15 Altitude/Wake prop w/1.76 trans v-drive
    Wet Sounds bow speakers & 10's on the Tower & ported sub

  3. #3
    Join Date
    Nov 2020
    Posts
    402

    Default

    You could have a leak through the prop shaft too…see how much water comes out after you pull out of the lake.


    Sent from my iPhone using Tapatalk

  4. #4
    Join Date
    Jan 2021
    Location
    Columbus, Ohio
    Posts
    1,264

    Default

    If the water develops using ballast, it is a bag, floor tank, hose, or pump.
    If the water appears magically, prop shaft, thru hull fitting, rudder box, heater circuit.

    My dripless is Glide now but my factory leaked after 595hrs.
    My rudder box o-ring (yep $0.15 part keeps boat floating) was replaced at 575hrs.
    2015 Moomba Mojo Surf Edition
    4,000lbs
    Manual Flow

  5. #5
    Join Date
    May 2020
    Location
    Nashville
    Posts
    229

    Default

    Excellent ideas, I need to do more testing this weekend. Plugs are good. No heater. I only noticed it after I filled ballast full and started surfing. After an hour the bilge pump came on. I'm going to run no ballast and bone dry next weekend to see if she leaks, If not then Ill start with doing the ballast one by one.

    Cheers homies for the help. I'll keep you posted.
    2018 Moomba MOJO
    4100lbs. ENZO's, Center Tank, IBS
    780lbs. Lead Wake
    Raptor 400
    Surf Prop: OJ 945
    2019 Ford F150 FX4
    5.0L V8

  6. #6
    Join Date
    Jan 2021
    Location
    Columbus, Ohio
    Posts
    1,264

    Default

    Quote Originally Posted by jnr4817 View Post
    Excellent ideas, I need to do more testing this weekend. Plugs are good. No heater. I only noticed it after I filled ballast full and started surfing. After an hour the bilge pump came on. I'm going to run no ballast and bone dry next weekend to see if she leaks, If not then Ill start with doing the ballast one by one.

    Cheers homies for the help. I'll keep you posted.
    Considering we have the same bow bag, check the hose connection under the storage locker. The fitting comes thru the wall and directly in the corner of the bag. My comes loose and will leak. Also, the vents on top of the same bag. I open mine under the bow cushions in winter and always forget to close them.
    2015 Moomba Mojo Surf Edition
    4,000lbs
    Manual Flow

  7. #7
    Join Date
    May 2020
    Location
    Nashville
    Posts
    229

    Default

    Thank you sir. Another place to check. I did run my hand on the carpet in the storage locker to see if it was wet and didn't feel any water. I also got eyes on it, but didnt do a thorough assessment, but Ill do a closer inspection, when filling each bag separately this weekend.
    2018 Moomba MOJO
    4100lbs. ENZO's, Center Tank, IBS
    780lbs. Lead Wake
    Raptor 400
    Surf Prop: OJ 945
    2019 Ford F150 FX4
    5.0L V8

  8. #8
    Join Date
    Jun 2020
    Location
    Utah
    Posts
    265

    Default

    Do you notice any loss of volume in any ballast bag after running for a while? We had a slow leak through a fitting in one of our bags that want from minor to severe over about a month. I would also suggest checking the connections to all your pumps. Additionally, you can isolate your ballast tubing using the valves at the thru fitting, but make sure you don't close the one for your engine impeller.


    2016 Moomba Mojo Surf Edition
    2000 Sharpe Houseboat 70x16 (Lives at Lake Powell)

  9. #9
    Join Date
    May 2020
    Location
    Nashville
    Posts
    229

    Default

    I was OOT this past week. We are going to troubleshoot this weekend. I've got a place in place to check everything I can. I hope it's an easy find.
    2018 Moomba MOJO
    4100lbs. ENZO's, Center Tank, IBS
    780lbs. Lead Wake
    Raptor 400
    Surf Prop: OJ 945
    2019 Ford F150 FX4
    5.0L V8

  10. #10
    Join Date
    May 2020
    Location
    Nashville
    Posts
    229

    Default

    Ok I found the area for the source of the leak. It’s coming from the bow. It only happens when filling the bow ballast. It appears to happen when the hard tank is full and the bow bag starts to fill. I can see water actively draining from under the ballast hard tank on port side bilge. It flows a lot fills up the bilge up enough to turn pump on. For troubleshooting, I can see The connections of the hard tank and ballast pumps. No leaking front house.

    What other connections are up under the tank in the bilge I can’t access. If it nots a fitting then the hard tank has a crack in it. The bow ballast bag itself isn’t leaking either. I checked those. The only other place I can check is the thru hole from the bilge to under the helm where an elbow is to fill the bow bag from the hard tank.

    I have a few months of warranty left so I’m going to rank it to the dealer.

    Any other thoughts?
    2018 Moomba MOJO
    4100lbs. ENZO's, Center Tank, IBS
    780lbs. Lead Wake
    Raptor 400
    Surf Prop: OJ 945
    2019 Ford F150 FX4
    5.0L V8

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •