Results 1 to 9 of 9

Thread: Stereo Controls

  1. #1
    Join Date
    Oct 2008
    Location
    Barrington,IL
    Posts
    49

    Default Stereo Controls

    Does anyone else have problems with the auxiliary stereo remotes? The remote on the stern always works but the one next to the drivers seat works sometimes. No matter how hard I press the buttons, it just won't work. Any ideas?

  2. #2
    Join Date
    Jun 2009
    Location
    South West Colorado
    Posts
    764

    Default

    Check the wiring plug behind and make sure that it is not zip tied too tight. That can cause the wire connections to break contact occasionally or all together. Skiers choice installers seem to have a bad habit of being over zealous with the zipties on the wiring.

    The remotes are quite simple, just power and ground and then one signal wire to the stereo. Ensure each of these wires is contacting properly.

    Let us know if that does not work out for you.
    '08 Mobius LSV- SOLD!
    2017 Mojo Pro

  3. #3
    Join Date
    Oct 2008
    Location
    Barrington,IL
    Posts
    49

    Default

    Ok I'll give that a try, it'd be nice to be able to control the stereo for once. I'm sick of my riders always controlling the tunes.

  4. #4
    Join Date
    Sep 2008
    Posts
    21

    Default

    I'm having the same issue, and actually took it in to have it looked at under warranty, they did not change it saying I had to push the buttons firmly... whatever...

    The problem is that the crappy remote on there has rubber buttons, and the contact under them don't make contact... They do but you have to really push and feel around for them, not something I want to mess with while I'm trying to mute the stereo while trying to pick up my downed rider...

    I'm replacing with the kenwood remotes soon, more tactile, and better quality, now I'm done with my 1 yr warranty/dealer.

  5. #5
    Join Date
    Feb 2003
    Location
    Maryville, TN
    Posts
    284

    Default

    Check with your dealers everyone. There was a recent service advisory about this. Your dealer should have the fix.

  6. #6
    Join Date
    Jun 2008
    Location
    Eugene OR
    Posts
    1,786

    Default

    Do you know all the boats and years it affects or will affect?
    2008 Outback V - Sold but never forgotten.
    “Do not wait; the time will never be “just right.” Start where you stand, and work with whatever tools you may have at your command, and better tools will be found as you go along." -Napoleon Hill

  7. #7
    Join Date
    Sep 2008
    Posts
    21

    Default

    Well, like I said, my dealer determined they were not a problem, but probably didn't play with it much to notice the problem. I'm still going to replace mine,

  8. #8
    Join Date
    Sep 2008
    Posts
    21

    Default

    Update, replaced the driver remote today with the Kenwood KCA-RC50MR, and what a difference. Every time I hit a button it did what it was supposed to do, the old one would often times do nothing... Easy to install, fite the same holes as the old one, doing the rear remote next...

    Quote Originally Posted by tailgate View Post
    Well, like I said, my dealer determined they were not a problem, but probably didn't play with it much to notice the problem. I'm still going to replace mine,

  9. #9
    Join Date
    Sep 2009
    Location
    Copperas Cove, TX
    Posts
    1,761

    Default

    Quote Originally Posted by tailgate View Post
    Update, replaced the driver remote today with the Kenwood KCA-RC50MR, and what a difference. Every time I hit a button it did what it was supposed to do, the old one would often times do nothing... Easy to install, fite the same holes as the old one, doing the rear remote next...
    And surprisingly a "cheap" mod/upgrade for the boat. Good lookin out for us. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •