Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2007
    Location
    ky
    Posts
    10

    Default filling a ballast

    Ok im new with the wakeboard boats,I have a 03 lsv gravity games has all three fatory ballasts.The guy i got it from hasnt used them in the last year.I turned the valve in rear on he had it turned off.I tried moving sitting still everything but never could get them to fill, any ideas or what do i need try thanks

  2. #2
    Join Date
    May 2007
    Posts
    8

    Default

    Sometimes they just need priming. When mine haven't been filled in awhile I need to get going pretty fast sometimes20-25 mph before water will start to flow. Try that.

  3. #3
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    1,254

    Default

    Do you hear the fill pump running? when I can't get mine to fiill, I prime the pump by driving and filling just one bag, once that bag begins to fill, we stop and let all the bags continue to fill. Check you pump to make sure it is running.
    15 Mondo Surf Edition

    02 LSV - Traded In

  4. #4
    Join Date
    May 2007
    Location
    Greensboro, NC
    Posts
    44

    Default

    for some reason, i have no clue why, i have to pull my rear seat out and get to the engine and unscrew the clear filter and then i dump the water in there out and screw it back on and works every time. i have no clue why this would fix my ballast not filling but it does.

  5. #5
    Sled491 Guest

    Default

    My buddy has the same problem with his 06, you just have to be patient, keep the boat moving like the other guys said.

Similar Threads

  1. Rear Ballast Sac Filling Up
    By mhaneke in forum Service & Repair
    Replies: 3
    Last Post: 07-09-2007, 11:33 PM
  2. Ballast tanks filling on their own.
    By calpal10 in forum General Chat
    Replies: 4
    Last Post: 06-15-2007, 06:33 PM
  3. Ballast is filling on its own
    By Aquaholic in forum Service & Repair
    Replies: 4
    Last Post: 10-24-2005, 09:27 AM
  4. Ballast Bag Filling Itself! Help!!!
    By sailnfast in forum Service & Repair
    Replies: 3
    Last Post: 05-02-2005, 08:46 PM
  5. My new mobius ballast keeps filling up
    By Goodtimesjeff in forum Service & Repair
    Replies: 4
    Last Post: 09-01-2004, 11:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •