Results 1 to 5 of 5
  1. #1
    Join Date
    Aug 2018
    Location
    Nebraska
    Posts
    56

    Default What a CRAP weekend !!

    So had the family all loaded up and heading to the lake to meet my brother and his family with there boat for a fun 3day weekend boating camping enjoying company. Lake is 2.5 he drive where we were going . 1.5 hrs away , 4 of 5 lug nuts on my boat trailer decided 72mph was enough and broke off WITH the actual lugs . Side of the interstate for 2.5 hrs waiting for my brother (who owns a mechanic shop) . Unload the kids and wife get them to town . Brother comes back . Put new lugs in the hub but they are to short . Holding by a thread . Get to town and get everything done correctly and press new lugs into both sides of the axles. Day is SHOT !! Wake up next morning new wind in our sails and head to the lake . Get the boat off the trailer and in the water , 5mins later hear what sounds to be a explosion in the engine. Smoke starts pouring from the engine cover , lift it up ...both exhaust hoses exploded . This is my luck guys ....I swear to you

  2. #2
    Join Date
    Aug 2018
    Location
    Nebraska
    Posts
    56

    Default

    So getting those replaced and fixed ALSO taking the switch panel off and soldering the connections in that panel. Whoever designed those connections , in my opinion was a idiot . There is nothing to keep them securely seeded to the circut boards. The ground side stays decently but the main switch panel is just horrible . So MORE work on this boat . Has tested my limits the past year that's forsure

  3. #3
    Join Date
    Aug 2011
    Location
    Commerce Lake, MI
    Posts
    1,757

    Default

    If you exploded the exhaust hoses then something was not right. Iím guessing no water getting into the manifold jackets. Check to make sure the player pump impeller isnít shot.


    Sent from my iPhone using Tapatalk
    2017 Moomba Craz

  4. #4
    Join Date
    May 2018
    Posts
    1,038

    Default

    I recommend checking lug torque and air pressure a few times a season. I torqued lugs in the fall and checked them again in June and 5 of 20 lugs needed a few ft.lbs

    0.5 psi a week loss in tire press is not unusual either.


    Sent from my iPhone using Tapatalk

  5. #5
    Join Date
    Aug 2018
    Location
    Nebraska
    Posts
    56

    Default

    Appreciate it and yes obviously something wasnt right !! It was very hot very quickly so im guessing your 100% correct

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •