Results 1 to 7 of 7
  1. #1
    Join Date
    Oct 2017
    Location
    Aiken, SC
    Posts
    29

    Default 16' SA450 Depth & Temp Not Working??

    Hey folks, been a while since I've posted anything, but here is the problem. I took the boat out for the first time of the year a couple weeks ago and noticed that my Temp and depth readings are not working correctly. My water temp reading is -50F and my depth gauge continuously reads 0.0ft.

    I have about a 45 minute drive to the closest dealer, so I am trying to resolve the issue personally before i load her up. I did call the dealer who suggested that I turn the key to the ON position without starting and flip the battery switch off for 30 seconds. After repeating this several times with different time intervals, i haven't had any luck.

    If anyone has a clue of how to correct this issue, I would be very appreciative. On a side note, everything else is working just as it should.
    2016 SA 450

  2. #2
    Join Date
    May 2018
    Posts
    1,243

    Default

    Guessing your through hull transducer has failed.

    Easy swap, but not cheap


    Sent from my iPhone using Tapatalk
    2018 Supra SA 400
    Michigan

  3. #3
    Join Date
    Oct 2017
    Location
    Aiken, SC
    Posts
    29

    Default

    I am assuming from your response that the transducer covers both the temp and the depth?
    2016 SA 450

  4. #4
    Join Date
    May 2018
    Posts
    1,243

    Default

    I believe its an airmar DST800 triducer.

    Depth Speed and Temp


    Sent from my iPhone using Tapatalk
    2018 Supra SA 400
    Michigan

  5. #5
    Join Date
    Oct 2017
    Location
    Aiken, SC
    Posts
    29

    Default

    Is it typical for the speed to still work accurately with the other two functions not working correctly?

    I appreciate the help Larry
    2016 SA 450

  6. #6
    Join Date
    May 2018
    Posts
    1,243

    Default

    Not sure, is your 2016 still under warranty?


    Sent from my iPhone using Tapatalk
    2018 Supra SA 400
    Michigan

  7. #7
    Join Date
    Oct 2017
    Location
    Aiken, SC
    Posts
    29

    Default

    It is, except I just went through their warranty page which has the below EXCLUSION in it. This to me makes me think it wouldn't be covered, but it never hurts to call the dealer.

    (3. Hardware or other components fastened or adhered to the hull, deck, floor, or stringers of the Covered Boat
    2016 SA 450

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •