Page 1 of 6 123 ... LastLast
Results 1 to 10 of 55
  1. #1
    Join Date
    Oct 2016
    Location
    Wisconsin
    Posts
    213

    Default Anyone disappointed with 2019 stereo with wetsounds?

    i was setting up my boat this weekend and ended up working on the radio at bit. Trying to get it to sound good. I have the fusion head unit with 10" wetsounds on the tower.

    The sub barely makes noise, just vibrates, and there is a serious lack of tuning available on the radio itself. Any recommendations? any help on how to get this to sound better? i had an order X2 with JL Audio that sounded about 10x better than this setup.

    All i can find in the radio is Bass, mid, treble, and zones..
    2019 Mondo

  2. #2
    Join Date
    Feb 2013
    Location
    Grapevine, TX
    Posts
    4

    Default

    I agree, it is a bit disappointing but I don't think they set them up from the factory. It looks like most of the adjustments to the new systems are on the amp only you have to remove the lower amp cover to access the adjustments. I did a google search for Wetsounds syn dx adjustments and there is a pdf that pops up with step by step setup procedure. I haven't messed with mine too much yet but was going to start here. From the factory mine sounded good when listening to the hip hop but not so good with anything else and I'm thinking I need to adjust the gain on the sub channel as well as the crossover settings while listening to my typical music genre style.
    2019 Moomba Max
    2007 Moomba XLV GG - sold
    2006 Moomba Mobius - sold

  3. #3
    Join Date
    Oct 2010
    Location
    Lake Wylie NC Area
    Posts
    2,092

    Default

    If you try to cross over the Pre-amp signal, you end just competing with the amp's settings. So no need for these setting in the head, just send out a full range signal, which the head does. Adding or subtracting a little BASS, MID and TREBLE is all thats needed IMO.

    On the FUSION head unit, does the woofer zone level adjustment actually raise and lower the woofer level? May need to rest your hand on the woofer and feel for its change. Just note, woofer zone volume is a sub-zone of zone-1, so no matter what, if you lower zone-1, the woofer volume goes down.

  4. #4
    Join Date
    Oct 2016
    Location
    Wisconsin
    Posts
    213

    Default

    i adjusted everything at the head unit for each zone. Still not impressed. The sub vibrates, but i don't hear anything coming from it. There isn't enough bass if you ask me. I have not adjusted anything on the amps, only on the head unit.
    2019 Mondo

  5. #5
    Join Date
    Oct 2010
    Location
    Lake Wylie NC Area
    Posts
    2,092

    Default

    I understand, trying to help. Answer the above as well as what Hz did you set the woofer at in the head unit unit?

  6. #6
    Join Date
    May 2018
    Posts
    1,195

    Default

    Not sure if itís at all like the Supras, but music source makes a huge difference.

    Ie.....iPhone as source needs all EQ flat or some suggest the EQ off all together.


    Sent from my iPhone using Tapatalk
    2018 Supra SA 400
    Michigan

  7. #7
    Join Date
    Feb 2018
    Location
    Central Bama
    Posts
    399

    Default

    Here's video of the WetSounds F1 package (non-amplified cockpit speakers)l be sure you use decent headphones or have a sub on your PC otherwise you won't hear the bass https://youtu.be/_hHfCQuyGtE

    I'd check the amp settings like suggested above and not change cross-over too much on the head unit until you at least know how the amp was (or wasn't setup).
    2019 Moomba Max
    2016 Yamaha AR192 - sold

  8. #8
    Join Date
    Jun 2008
    Location
    Henderson, NV
    Posts
    5,285

    Default

    not sure how the setup is from ws but I know that on the last couple tige's I have auditioned the ws factory sub in an IB location doesn't lend itself to earth shattering bass. it's the weakest link in the speaker chain imo.

    good luck and hope you discover the magic bullet for the rest of the system but sub really needs a different model in a sealed/ported box.
    '06 Supra Launch 20SSV-gone but never forgotten

  9. #9
    Join Date
    Oct 2016
    Location
    Wisconsin
    Posts
    213

    Default

    Quote Originally Posted by larry_arizona View Post
    Not sure if it’s at all like the Supras, but music source makes a huge difference.

    Ie.....iPhone as source needs all EQ flat or some suggest the EQ off all together.


    Sent from my iPhone using Tapatalk
    iPhone EQ? Tell me more. Willing try anything. I checked mine and eq was off. Maybe try bass booster mode?
    Last edited by jason1973; 04-29-2019 at 09:14 PM.
    2019 Mondo

  10. #10
    Join Date
    May 2018
    Posts
    1,195

    Default

    Equalizer = EQ

    You want your phone EQ off or flat as it causes distortion when combined with the EQ settings on a Supra system.

    Took a highly disappointing Supra JL system and made it STELLAR after fixing my phone.

    Night and day difference.


    Sent from my iPhone using Tapatalk
    2018 Supra SA 400
    Michigan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •