Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23
  1. #11
    Join Date
    Jun 2018
    Posts
    12

    Default

    The mechanic is saying that the fuel pump is bad. I told them to replace it. He said it may be a couple weeks before it's ready
    2011 Moomba XLV 325 Indmar Assault

  2. #12
    Join Date
    Jan 2006
    Location
    Jacksonville, FL
    Posts
    599

    Default

    Quote Originally Posted by mstopher82 View Post
    Thanks for the suggestion. Do you remember what part number it was or where you ordered it?
    Not off the top of my head. That boat is long gone. Good luck. Did they put a pressure gauge on the pump while it was running and underload to verify the pump isn’t producing what it should? If they just start throwing parts at it and it doesn’t fix it I wouldn’t be happy. Wonder why a couple weeks on an external fuel pump.

  3. #13
    Join Date
    May 2018
    Posts
    7

    Default

    It could be the fuel pump I guess but it certainly sounds like a fire issue to me, especially being off and on. I'm not a mechanic of course.

  4. #14
    Join Date
    Jun 2018
    Posts
    12

    Default

    Quote Originally Posted by 98outback View Post
    Not off the top of my head. That boat is long gone. Good luck. Did they put a pressure gauge on the pump while it was running and underload to verify the pump isn’t producing what it should? If they just start throwing parts at it and it doesn’t fix it I wouldn’t be happy. Wonder why a couple weeks on an external fuel pump.
    From my understanding it is not an external pump. They moved the fuel pumps and filter into the fuel tank in '09 or '10 to prevent the vapor lock issues they were having.
    2011 Moomba XLV 325 Indmar Assault

  5. #15
    Join Date
    Apr 2012
    Posts
    169

    Default

    Quote Originally Posted by Smoothwater View Post
    It could be the fuel pump I guess but it certainly sounds like a fire issue to me, especially being off and on. I'm not a mechanic of course.
    I had an issue with my boat stopping us and leaving us stranded multiple times a few summers ago. It would start right up and run for 30 mins or so and shut off and leave us stranded. It was our low pressure fuel pump. Had it replaced and been good since. 2000 nautique not a moomba. Not sure if that's helpful or not, just another perspective.

  6. #16
    Join Date
    May 2018
    Posts
    1

    Default

    Smoothwater What is the coil pack and where is it located? I have a 2005 Moomba Indmar Assult 5.7 EFI that I just recently purchased and believe that what you had going on is the what I have going on. Can you help with location and part number?

  7. #17
    Join Date
    Aug 2011
    Location
    Commerce Lake, MI
    Posts
    1,762

    Default

    Quote Originally Posted by Leland View Post
    Smoothwater What is the coil pack and where is it located? I have a 2005 Moomba Indmar Assult 5.7 EFI that I just recently purchased and believe that what you had going on is the what I have going on. Can you help with location and part number?
    Follow the single lead going into the distributor back, and you will see the coil pack. Typically mounted above the v-drive trans


    Sent from my iPad using Tapatalk
    2017 Moomba Craz

  8. #18
    Join Date
    May 2018
    Posts
    7

    Default

    Quote Originally Posted by Stazi View Post
    Follow the single lead going into the distributor back, and you will see the coil pack. Typically mounted above the v-drive trans


    Sent from my iPad using Tapatalk
    What he says.

  9. #19
    Join Date
    Jun 2018
    Posts
    12

    Default

    Just an update. Mechanic is leaning away from it being the fuel pump. He says that it is coming on every time he keys it up. He told me he has an ohm diagram (maybe a wire diagram?) and is tracing backwards from the fuel pump. I guess they will find the problem eventually.
    2011 Moomba XLV 325 Indmar Assault

  10. #20
    Join Date
    Jun 2018
    Posts
    12

    Default

    Sorry so long to get back on but we have been at the lake �� as to what was wrong with it I'm still not sure. The mechanic had it twice first time he said nothing was wrong. Well that wasn't the case. He had it for about 2 weeks called and said he thought may be a fuel pump
    He called the week after that and said it was running fine. However, he didn't replace the fuel pump or anything. No charge for looking at it the second time. They said it was the "magic touch", whatever that means. But hey! The boat runs great and we love it! Now on to my next issue, diagnosing the ballast tanks that are not filling SMH!
    2011 Moomba XLV 325 Indmar Assault

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •