Could be a fluke, please feel free to give your advice. I just replaced my MDC and tach in my 2000 Outback LS and went to start it, wanted to see that new tach move! (and I wanted to see oil pressure activity on the gauge for the 1st time ) Did my normal routine, prime the throttle twice to set the choke, bring it back to a little off idle, turn the key. It fired up for a second and then died when touching the throttle to keep it running. Tried again and kept firing then dying until nothing more than cranking now - no fire what so ever.

I found out at an earlier time i can get the battery + lead to touch the post on the solenoid that drives the fuel pump, so I did this for 5-10 seconds. Turned the key and it at least fired, but only for a second. Now I have done enough reading on this forum to jump all over my oil pressure switch, however, the last time out we had no problems at all... is there anything in a MDC that would contribute to the above problem? I swapped back to the old one for the heck of it and still no fire.

Assuming you guys all post back saying it's my oil switch, can these be sourced locally? (Napa, O'Rielly's, etc) and if so, any P/N suggestions? Trying to get out on the water tomorrow!

Last question then I'll hit post! Three wires coming off the switch, but the electrical diagram shows the switch as a normally open circuit with only one wire. Which ones do you jump to take the oil switch out of the circuit?

Thanks for the help guys, this forum is great!