Results 1 to 2 of 2
  1. #1

    Default Tower Speakers not on, but have power (lights)

    its a relatively new to me boat...2008 XLV. I worked thru so many things last year the speakers really weren't a high priority. My wife swears the tower speakers worked last year, but I don't remember.

    There are 6 speakers and a sub in the boat. they all work just fine. 2 amps located by the battery, both light up so they appear to be working.

    No sound comes out of the 4 tower speakers, though they do have LED lights on them that come on, so I know they have power.

    Where do I begin to trouble shoot? I feel like they have to be plugged in since they have power? Is it a setting on the actual stereo?

    Thanks for any insight!
    2008 XLV Gravity Games edition

  2. #2
    Join Date
    Oct 2010
    Location
    Lake Wylie NC Area
    Posts
    2,429

    Default

    Any speaker LEDs will have their own wire harness and power supply, and it entirely separate from the audio wires that carry the music.

    Start at the amp. Is there a power light on? Is it red or blue or green? Red typically indicates a protect mode, where as blue or green are the typical colors used for normal mode.

    No light could mean the amp is toast or there is no voltage on the power cable, low voltage or no voltage on the small turn-on wire. Red light can mean the amp is toast, low voltage, high voltage or shorted speaker.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •