Results 1 to 3 of 3
  1. #1

    Default Raw water pump mounting stud failure

    Hello,
    I have a 2016 Craz with the standard Raptor engine. The only problems I have had since I bought the boat new are related to the Raw water pump. About 3 yrs ago one of the brackets that support the water pump broke. Yesterday I discovered the stud bolt that mounts the bracket to the engine sheared off. I was able to retrieve the stud bolt with a 7/8 socket. The parts guy had a hard time figuring out which part I needed. Pictures help. Not sure if anyone has had this problem but I thought I would post. The part number is in the picture.
    72FA1B1D-DCE8-434C-AEAA-CDA2B898DCE7.jpg
    3F369AB8-2F70-4ACA-AAA8-D8CB96D56355.jpg
    2FD2A83F-5EBF-441A-9AB7-08E5DF87F4AC.jpg
    F1227D86-C01D-47B5-B9C4-3E93AFB9580C.jpg

  2. #2
    Join Date
    Jan 2021
    Location
    Columbus, Ohio
    Posts
    971

    Default

    When I bought my boat second hand that bolt and the 2 bolts that mount the bracket together were all loose.

    I removed, added blue locktite, re-torqued. Has been good ever since.
    2015 Moomba Mojo Surf Edition
    4,000lbs
    Manual Flow

  3. #3
    Join Date
    Jun 2022
    Location
    White Plains, New York
    Posts
    10

    Default

    My son also had the same problem with his boat and bolt replacement helped him, but I don't know if it was the same detail or not.
    Moomba Outback V-Drive - 2010 (sold)
    Moomba Makai - 2020

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •