Results 1 to 5 of 5
  1. #1
    Join Date
    Nov 2020
    Posts
    148

    Default 17 Supra SA water temp not reading

    Any ideas how to fix or troubleshoot? Still reads -50 when water is in the low 70s by now.

    Thanks!


    Sent from my iPhone using Tapatalk

  2. #2
    Join Date
    May 2018
    Posts
    3,416

    Default 17 Supra SA water temp not reading

    I think 2017 uses an airmar triducer for speed, depth and water temp.

    They are known to go bad, but easy to replace.

    Not cheap though at $275-$300


    Sent from my iPhone using Tapatalk
    2021 Supra SA 400
    2018 Supra SA 400 (SOLD)
    Michigan

  3. #3
    Join Date
    Nov 2020
    Posts
    148

    Default

    Speed and depth are still accurate. Can one of them go bad individually?


    Sent from my iPhone using Tapatalk

  4. #4
    Join Date
    May 2018
    Posts
    3,416

    Default

    Quote Originally Posted by eder10986 View Post
    Speed and depth are still accurate. Can one of them go bad individually?


    Sent from my iPhone using Tapatalk
    Yes.


    Sent from my iPhone using Tapatalk
    2021 Supra SA 400
    2018 Supra SA 400 (SOLD)
    Michigan

  5. #5
    Join Date
    Jan 2017
    Posts
    14

    Default

    I have had my triducer replaced 3 times under warranty on my 17 SR. All three times my screen read -50.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •