Results 1 to 6 of 6
  1. #1
    Join Date
    Jun 2020
    Posts
    4

    Default 2018 Moomba Craz not working correctly 2nd summer

    I have a 2018 Craz and have issues with the wake plates, tabs, and speed control since the day I put it the water. This is the second summer and I am getting tired of not being able to use this boat and having the dealer and skiers Choice tell me that they will figure out the problem. They work on it say its fixed then the plates freeze or the cruise control fail or the side plates randomly go on at the same time. These are not the only problems I have had just the most common. Any thought on how to deal with this. I really don't know what to do and feel that this may be a lemon? Is my only option to just hope it gets fixed some day?

  2. #2
    Join Date
    Jan 2017
    Location
    Katy, TX
    Posts
    1,208

    Default

    When you start your boat, do you just crank it up?

    Or do you turn ignition halfway, allow screen/tabs/etc. to power cycle, then full ignition?

    Sent from my Note 9 using Tapatalk
    2017 Moomba Craz Surf MAX Edition
    Flow 2.0 Surf System w/ AutoWake™
    5,600 Lbs Ballast - Enzos + Lead + Sumo
    Wet Sounds REV10s + REVO12-XXX

  3. #3
    Join Date
    Jun 2020
    Posts
    4

    Default

    Turn key and start.

  4. #4
    Join Date
    Jan 2017
    Location
    Katy, TX
    Posts
    1,208

    Default

    I've had my plates wig out before on my 17 Craz.

    Turning off the boat, turning ignition halfway to power cycle and then full ignition generally did the trick.

    During the power cycle you should see your gauges sweep back and forth, your screen should boot and your tabs should reset.

    You can even try this on the trailer, you'll hear the actuators for the tabs adjusting.

    Sent from my Note 9 using Tapatalk
    2017 Moomba Craz Surf MAX Edition
    Flow 2.0 Surf System w/ AutoWake™
    5,600 Lbs Ballast - Enzos + Lead + Sumo
    Wet Sounds REV10s + REVO12-XXX

  5. #5
    Join Date
    Jun 2020
    Posts
    4

    Default

    its back at the shop but I will try that when I get it back. in the past I have turned the boat off then the batteries off and on and it would reset and work far a while but lately that dosent work either.

    I would think after a summer and a half the dealer and Skiers Choice would be able to make it work. Extremely frustrating!

  6. #6
    Join Date
    Aug 2015
    Location
    Mn
    Posts
    343

    Default

    When you start the boat, make sure your surf tab toggle is in the middle position. Before you flip the toggle for surfing, make sure you allow the ECU to cycle through its diagnostics. If the toggle was left on the starboard position when the engine is turned off, when you turn it back on, if the toggleis still flipped to the side, it'll mess up the whole diagnostics run and cause all kinds of issues. I dealt with this for a year, even my dealer didn't know what was going on. I called SC and they explained this to me. Not a problem since. THis was on my '15 Mojo.
    Always ensure the toggle is in the middle position and wait a few secs for all the gauges to settle and then flip it for surfing.
    2020 Supra SL 400
    2015 Moomba Mojo(Sold)
    2018 Yamaha Waverunner(Just to fool around)
    2018 F150 Lariat
    sport edition, 3.5lt ecoboost

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •