Results 1 to 3 of 3
  1. #1
    Join Date
    Sep 2018
    Location
    North Carolina
    Posts
    37

    Default Raptor engine knocking noise at idle- Throttle body servo

    This is the 2nd time I have posted this issue. I am still hearing this noise after running the engine and then putting the engine at idle. I only have until March 2020 until the warranty runs out. I found the following clip on a Tige forum today but this is exactly what I am experiencing.

    https://youtu.be/X89a31Bl45s

    Any idea the cause or fix?
    2015 Moomba Mondo Surf Edition
    WM 910 Rear sacs and 650 and 550 IBS
    WS 600 WATT Amp- 4 Tower Speakers
    KICKER 800 WATT Amp-Sub
    Ford Raptor 400 6.2 L
    Pro sport 12 Dual Batt Charger
    Acme Prop 14.5 x 14.25

    Winston Salem
    North Carolina

  2. #2
    Join Date
    Aug 2015
    Location
    Spokane, WA
    Posts
    258

    Default

    Sorry to here you’re having issues. The warranty doesn’t require you to diagnose the issue. Take it to your dealer. As long as you get it in before the warranty runs out; if they can’t resolve it at one visit, they still have to cover it under the original warranty.

    Are you sure it’s not just the lifters? All engines have lifter “tick”.

    Keep us posted.


    Sent from my iPhone using Tapatalk Pro
    2008 Moomba Mobius LSV

  3. #3

    Default

    I have this same sound. I would bet it's the same thing. I'll check and see and report back when we're back at the lake. Although if it's not sticking when hitting the throttle, I wouldn't mess with it.
    2016 Mojo surf edition
    1100lbs rear w/ 475lbs piggyback mid/ center 700lbs/ 500lbs IBS/ 600 lbs lead
    ACME 2315

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •