Results 1 to 6 of 6
  1. #1
    Join Date
    Jun 2019
    Location
    Germany
    Posts
    4

    Default 2017 Craz GPS/Paddlewheel cruise, Autowake & other Q

    Hello,

    i am from Germany and bought a used 2017 Craz a few days ago. I already found some electrical things that need to be fixed or changed.

    1. 1. As i am using it for wakeboarding and wakesurfing on a river, i noticed the typical GPS cruise problem of bouncing throttle while turning verry early.
      I was told to disconnect the GPS antenna but i cant find it or any connector of it.

      Can anybody tell me where to find it? What else is (negatively) affected by disconecting GPS?

    2. 2. I tried to get into autowake while only ignition was on and the boat was on the trailer and it didnt show up, it just switched on cruise controll by pressing the left button.

      Did i use it the wrong way or is the boat not equipped with autowake? Was it a optional purchase?

    3. 3. Watertemperature shows 0 when i turn it on. I was told the value is delivered by a three way sensor (temp, depth, and paddle wheel speed). I am able to see water depth and the boat has a paddle wheel so i think it has to show watertemperature, too.

      Any ideas what could be the reason for this issue and how to fix it?

  2. #2
    Join Date
    Nov 2010
    Location
    Katy, TX
    Posts
    5,960

    Default

    Quote Originally Posted by Sebber1.8T View Post
    Hello,

    i am from Germany and bought a used 2017 Craz a few days ago. I already found some electrical things that need to be fixed or changed.

    1. 1. As i am using it for wakeboarding and wakesurfing on a river, i noticed the typical GPS cruise problem of bouncing throttle while turning verry early.
      I was told to disconnect the GPS antenna but i cant find it or any connector of it.

      Can anybody tell me where to find it? What else is (negatively) affected by disconecting GPS?

    2. 2. I tried to get into autowake while only ignition was on and the boat was on the trailer and it didnt show up, it just switched on cruise controll by pressing the left button.

      Did i use it the wrong way or is the boat not equipped with autowake? Was it a optional purchase?

    3. 3. Watertemperature shows 0 when i turn it on. I was told the value is delivered by a three way sensor (temp, depth, and paddle wheel speed). I am able to see water depth and the boat has a paddle wheel so i think it has to show watertemperature, too.

      Any ideas what could be the reason for this issue and how to fix it?
    For autowake you have to press the left button twice. If pressing it twice just toggles zero off on then off again then I would say your boat is not equipped with autowake.
    David

    2017 Moomba Mojo Max Surf Edition, 2 Pair Wetsounds Rev10s powered by an SD2, 6 pair Wetsounds XS650M and Wetsounds XS12 powered by SD6 all controlled by a WS420.

    SOLD***2008 Mobius LSV, Gravity III , Wake Plate, Z5, Exile SX65c's, Exile XM9s, Exile XI12D, Exile Javelin, Exile 30.2***SOLD

  3. #3
    Join Date
    Jun 2019
    Location
    Germany
    Posts
    4

    Default

    Quote Originally Posted by rdlangston13 View Post
    For autowake you have to press the left button twice. If pressing it twice just toggles zero off on then off again then I would say your boat is not equipped with autowake.
    thats exactly what happens while pressing it twice, i thought about the engine has to be running, or some speed is needed...
    Well, if its not any of these possibilities, than a update would be nice if possible??

  4. #4
    Join Date
    Nov 2010
    Location
    Katy, TX
    Posts
    5,960

    Default

    Quote Originally Posted by Sebber1.8T View Post
    thats exactly what happens while pressing it twice, i thought about the engine has to be running, or some speed is needed...
    Well, if its not any of these possibilities, than a update would be nice if possible??
    I believe the software may be the same with or without autowake. The inclinometer may be the only thing needed.
    David

    2017 Moomba Mojo Max Surf Edition, 2 Pair Wetsounds Rev10s powered by an SD2, 6 pair Wetsounds XS650M and Wetsounds XS12 powered by SD6 all controlled by a WS420.

    SOLD***2008 Mobius LSV, Gravity III , Wake Plate, Z5, Exile SX65c's, Exile XM9s, Exile XI12D, Exile Javelin, Exile 30.2***SOLD

  5. #5
    Join Date
    Jun 2019
    Location
    Germany
    Posts
    4

    Default

    Quote Originally Posted by rdlangston13 View Post
    I believe the software may be the same with or without autowake. The inclinometer may be the only thing needed.
    is there any source to look for moomba spare parts/optional parts...? do you have any thoughts about my other questions?

  6. #6
    Join Date
    Nov 2010
    Location
    Katy, TX
    Posts
    5,960

    Default

    Quote Originally Posted by Sebber1.8T View Post
    is there any source to look for moomba spare parts/optional parts...? do you have any thoughts about my other questions?
    Only place I canít think of for parts like that is a dealer.

    As far as the other questions, my gps cruise works awesome so Iíve never bothered looking for how to disconnect the antenna and Iím not sure on your triducer question



    Sent from my iPhone using Tapatalk
    David

    2017 Moomba Mojo Max Surf Edition, 2 Pair Wetsounds Rev10s powered by an SD2, 6 pair Wetsounds XS650M and Wetsounds XS12 powered by SD6 all controlled by a WS420.

    SOLD***2008 Mobius LSV, Gravity III , Wake Plate, Z5, Exile SX65c's, Exile XM9s, Exile XI12D, Exile Javelin, Exile 30.2***SOLD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •