Page 1 of 3 123 LastLast
Results 1 to 10 of 25
  1. #1
    Join Date
    May 2013
    Location
    Vancouver WA
    Posts
    4,897

    Default 340 CAT ETX intermittent surging with 3000 RPM limit or it'll die and not start

    Need Help. (posting here as well as on the FB group) Boat has intermittent power loss and sometimes even dies. I'll try to be as specific as possible. It's a 2008 Moomba XLV with the 340 CAT ETX engine.

    Towards the end of the summer, the boat developed a problem where it suddenly lost about half its power and would cap itself at exactly 3,000 RPM's. This problem was VERY intermittent. Some days it'd run perfect. Others it'd run for 20 minutes then have this problem, then the problem would mysteriously go away and the boat would run perfect again. When the problem materializes, the boat's RPM's would surge and eventually settle to exactly 3000 RPM's. When I've run it on the hose, the Fuel pressure at the rail was in a normal range but the needle would surge with the RPM's of the boat.

    Last week, the boat had trouble starting a couple times, and ultimately the 2nd time it wouldn't start no matter how long I cranked it. I really felt like it must be the fuel pump and replaced BOTH the low pressure and high pressure fuel pumps. Ultimately we couldn't even keep the boat running (if it would even start) and had to get towed 7 miles to the dock.

    Today I took it out and after 20 minutes it had the hiccup where it lost power and capped itself at 3000 RPMs. And then it ran fine for a while, and then it was back to low power and 3000 RPMs. It did this on and off the whole time it was out. Toward the end of today (we were just floating near the launch by this point) it started escalating to where the engine quit a couple times (we got it on the trailer ASAP).

    ***There are NO CHECK ENGINE LIGHTS*** Never has a CEL ever lit up. (just to be sure, I ran the engine on the hose and unplugged a couple O2 sensors to verify that the CEL does in fact light up). 2 years ago I had surging but it was different where the boat wouldn't even get up to 3000 RPM's and a CEL did come on with that one and it was ultimately fixed with all the tuneup stuff (including wires).

    Here are the things I've tried:
    - Replaced fuel filter
    - Seafoam and Heet
    - Replaced Spark Plugs
    - Replaced Cap & Rotor
    **I did all of the above, as well as the plug wires also in 2016. (that said, I believe I've been putting 150-175 hours on annually)

    I do have a squeaky alternator that I haven't replaced yet, but my charging voltage is never low on the gauge. Oil level is fine and oil pressure is not low (it tends to actually be on the high side). Engine temp is fine.

    I'm running out of time to be able to get it on the water, so I don't know if I'll even be able to fix this before I have to winterize.

    I talked to the dealer and they said that they'd have to put the boat in the water and replicate the problem to diagnose. But it'd been so intermittent that I just saw that as money flying out of my pocket.

    I'm wondering if it's a sensor??? (Crank Position? Throttle Position? Engine temp sensor?)
    2008 Moomba Mobius XLV. Monster Cargo Bimini, WS Rev 410's, Polk Cabins, 3 Infinity Subs, PPI amps, WS420, Exile BT, upgraded ballast pumps, up to 3,500+ pounds of ballast, Blue LED's...
    1992 Supra Sunsport. **SOLD** 2k pounds ballast, Surf System, Blue LED's everywhere, decent audio system.
    Tow Rig: 2013 F150 Ecoboost FX4 (wife's rig) Other money pits include:1998 BMW M3 Cabriolet, 2009 Audic A6 Avant 3.0T, 2005 Kawasaki ZX-6R 636.
    www.TraysonsToybox.com

  2. #2
    Join Date
    Sep 2015
    Location
    Conroe, TX
    Posts
    910

    Default

    How is it running when it limits itself to 3000? Idle normal even though it surges Just won’t rev past 3k?
    Sounds like the ECU is going into a limp mode.
    I would replace the ignition coil, when they die it’s usually slow and causes problems.
    Overkill is underrated

    2006 Supra 24SSV Gravity Games- traded but never forgotten

    2017 Supra SA 400

  3. #3
    Join Date
    May 2013
    Location
    Vancouver WA
    Posts
    4,897

    Default

    Quote Originally Posted by Broke Pilot View Post
    How is it running when it limits itself to 3000? Idle normal even though it surges Just won’t rev past 3k?
    Sounds like the ECU is going into a limp mode.
    I would replace the ignition coil, when they die it’s usually slow and causes problems.
    Definite and noticeable loss of power. When I give it throttle from neutral to WOT, it surges, goes a tiny bit above 3k and then settles to 3k on the nose.
    2008 Moomba Mobius XLV. Monster Cargo Bimini, WS Rev 410's, Polk Cabins, 3 Infinity Subs, PPI amps, WS420, Exile BT, upgraded ballast pumps, up to 3,500+ pounds of ballast, Blue LED's...
    1992 Supra Sunsport. **SOLD** 2k pounds ballast, Surf System, Blue LED's everywhere, decent audio system.
    Tow Rig: 2013 F150 Ecoboost FX4 (wife's rig) Other money pits include:1998 BMW M3 Cabriolet, 2009 Audic A6 Avant 3.0T, 2005 Kawasaki ZX-6R 636.
    www.TraysonsToybox.com

  4. #4
    Join Date
    May 2013
    Location
    Vancouver WA
    Posts
    4,897

    Default

    How would you verify/diagnose the coil???

    https://www.bakesonline.com/indmar-h...th-module.html
    2008 Moomba Mobius XLV. Monster Cargo Bimini, WS Rev 410's, Polk Cabins, 3 Infinity Subs, PPI amps, WS420, Exile BT, upgraded ballast pumps, up to 3,500+ pounds of ballast, Blue LED's...
    1992 Supra Sunsport. **SOLD** 2k pounds ballast, Surf System, Blue LED's everywhere, decent audio system.
    Tow Rig: 2013 F150 Ecoboost FX4 (wife's rig) Other money pits include:1998 BMW M3 Cabriolet, 2009 Audic A6 Avant 3.0T, 2005 Kawasaki ZX-6R 636.
    www.TraysonsToybox.com

  5. #5
    Join Date
    Jan 2006
    Location
    Jacksonville, FL
    Posts
    600

    Default

    Our last Supra has the Indmar 325 and it had some of the same symptoms. Dealer kept throwing parts and I did my own research online. Finally I told them just to make me happy change the coil. They did and never another problem. It started out slow and as time went on the boat become unusable. Try the coil before you spend to much more. Not to expensive.

  6. #6
    Join Date
    Sep 2015
    Location
    Conroe, TX
    Posts
    910

    Default

    Quote Originally Posted by trayson View Post
    How would you verify/diagnose the coil???

    https://www.bakesonline.com/indmar-h...th-module.html
    They can be tested, but it’s not worth it and usually not a reliable test. Usually when you do the cap and rotor you wanna do the coil with it. They’re all wear items.
    If it’s not getting enough spark, the ecu may be trying to protect the motor.
    You’ve verified fuel, so spark is the only logical item left.
    The only other thing it might be on the fuel side is the fuel pressure regulator. It might be dying. Only way to tell though would be to hook it up and scan commanded vs actual fuel pressure. Not sure if that’s a computer or mechanical check though. You said the needle would surge with rpm when you tested fuel pressure.
    I’d look at the regulator hard after re-reading your post. EFI usually wants a pretty steady pressure. I’m not sure if these boats use a return style fuel system or not.
    Last edited by Broke Pilot; 10-28-2018 at 12:45 AM.
    Overkill is underrated

    2006 Supra 24SSV Gravity Games- traded but never forgotten

    2017 Supra SA 400

  7. #7
    Join Date
    Sep 2015
    Location
    Conroe, TX
    Posts
    910

    Default

    Well... how’s it going?
    Overkill is underrated

    2006 Supra 24SSV Gravity Games- traded but never forgotten

    2017 Supra SA 400

  8. #8
    Join Date
    May 2013
    Location
    Vancouver WA
    Posts
    4,897

    Default

    Quote Originally Posted by Broke Pilot View Post
    Well... hows it going?
    Things done before last test:
    • Cap
    • Rotor
    • Plugs
    • Fuel Filter
    • Seafoam
    • New high pressure fuel pump
    • New low pressure fuel pump


    Things completed as of last night:
    • found a worn part of the insulation on the wire harness for the ignition coil that was possibly exposing the white control wire to a short, fixed
    • New fuel hoses from fuel filter to pumps and from LP to HP pump
    • New plug wires (found corrosion on coil plug wire)
    • Re-Gapped Spark plugs to spec 0.060" per owners manual
    • New Ignition Coil


    I hope to get it on the water tonight or more likely tomorrow.
    2008 Moomba Mobius XLV. Monster Cargo Bimini, WS Rev 410's, Polk Cabins, 3 Infinity Subs, PPI amps, WS420, Exile BT, upgraded ballast pumps, up to 3,500+ pounds of ballast, Blue LED's...
    1992 Supra Sunsport. **SOLD** 2k pounds ballast, Surf System, Blue LED's everywhere, decent audio system.
    Tow Rig: 2013 F150 Ecoboost FX4 (wife's rig) Other money pits include:1998 BMW M3 Cabriolet, 2009 Audic A6 Avant 3.0T, 2005 Kawasaki ZX-6R 636.
    www.TraysonsToybox.com

  9. #9
    Join Date
    May 2013
    Location
    Vancouver WA
    Posts
    4,897

    Default

    I ran it through the paces. There and back 7 miles each way at 3500 RPMs. Then four of the 2.5 mile lengths of our slough. 1 with no ballast at 28mph, 1 with 1180lbs at 21.5mph, and 2 at 10mph with 3000+ lbs of ballast. No issues and the fuel consumption seemed better than it's been lately. So hopefully I'm finally in good shape.
    2008 Moomba Mobius XLV. Monster Cargo Bimini, WS Rev 410's, Polk Cabins, 3 Infinity Subs, PPI amps, WS420, Exile BT, upgraded ballast pumps, up to 3,500+ pounds of ballast, Blue LED's...
    1992 Supra Sunsport. **SOLD** 2k pounds ballast, Surf System, Blue LED's everywhere, decent audio system.
    Tow Rig: 2013 F150 Ecoboost FX4 (wife's rig) Other money pits include:1998 BMW M3 Cabriolet, 2009 Audic A6 Avant 3.0T, 2005 Kawasaki ZX-6R 636.
    www.TraysonsToybox.com

  10. #10
    Join Date
    Apr 2013
    Location
    Knoxville TN
    Posts
    1,344

    Default

    Im hope to see a good black-Friday sale on all the tune up items.


    Sent from my iPhone using Tapatalk
    2018 Supra SL400

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •