Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2018
    Posts
    13

    Default Missing oil pressure gauge. Possible it wasnít an option?

    Hey guys the boat is a 2005 moomba mobius LSV. I bought the boat not too long ago and have been fixing some issues along the way thanks to your help. There is a blank gauge on the dash with no needle or numbers Iím assuming where the oil pressure gauge should be. I didnít question it when I bought it since it was a blank gauge. Is this normal or did someone replace the gauge with a blank one? Was it an option for that year? I feel like oil pressure should be standard. Anyways here are a few pictures of the gauge and behind the console looks like there is a connector hanging there for the oil pressure I could be wrong? Check the pics and let me know what you think. I tried looking around in the motor for an like pressure sender but couldnít locate anything that looked like it. Where can this be found?
    Attached Images Attached Images

  2. #2
    Join Date
    Sep 2005
    Location
    Claytor Lake, VA
    Posts
    454

    Default

    Oil pressure gauge should be standard. What gauges do you have on the right near the throttle? That's where the optional wakeplate and depth gauges would be and should be the only place where blank gauges whould have been installed.
    2005 Mobius LSV
    325 EFI

  3. #3
    Join Date
    May 2013
    Location
    Vancouver WA
    Posts
    4,585

    Default

    My oil sender is basically right by the remote oil filter housing. just to the stern of the oil filter.

    I have an oil pressure gauge that I pulled off my boat when I swapped out to a digital one. I think it was my sender that was bad, but I replaced both. I don't know if my guage is good or not, but if you have a harness maybe it'd work? I could take a look at the back of it and see if that is what would mate up with yours. It's just 3 or 4 wires IIRC.
    2008 Moomba Mobius XLV. Monster Cargo Bimini, WS Rev 410's, Polk Cabins, 3 Infinity Subs, PPI amps, WS420, Exile BT, upgraded ballast pumps, up to 3,500+ pounds of ballast, Blue LED's...

    1992 Supra Sunsport. **SOLD** 2k pounds ballast, Surf System, Blue LED's everywhere, decent audio system.


    Tow Rig: 2013 F150 Ecoboost FX4 (wife's rig) Other money pits include:1998 BMW M3 Cabriolet, 2009 Audic A6 Avant 3.0T, 2005 Kawasaki ZX-6R 636.

  4. #4
    Join Date
    Sep 2018
    Posts
    13

    Default

    Quote Originally Posted by trayson View Post
    My oil sender is basically right by the remote oil filter housing. just to the stern of the oil filter.

    I have an oil pressure gauge that I pulled off my boat when I swapped out to a digital one. I think it was my sender that was bad, but I replaced both. I don't know if my guage is good or not, but if you have a harness maybe it'd work? I could take a look at the back of it and see if that is what would mate up with yours. It's just 3 or 4 wires IIRC.
    Much appreciated. So behind where the blank gauge is there is a 4 wire connector underneath the dash. I was also able to locate the sender and the wiring that goes to it. The wire on the tip of the sender was unplugged. I wonder why. Anyway here are some pictures of what I found. What’s the other wires connector right next to the sender? Is that an oil sensor?

    EAD68E4F-342B-413E-AD12-F52396EB8D1C.jpg
    C90CE034-B154-4B83-B3B3-043A871583E5.jpg
    Last edited by Fisherman302; 10-12-2018 at 06:50 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •