Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2015
    Location
    Melbourne, Australia
    Posts
    77

    Default How to run speaker wires OzHD tower

    Hey guys, just doing a few things to the boat over the weekend and was curious to know how folk ran wires for a pair of speakers upon their OZHD towers. Was looking at the possibility of running wires up the port side but cannot seem to find a way to get the wiring near the grommets mounted.
    Are the intersecting tubes drilled with holes to allow wires to be passed thru?
    Had a look on the forum and googled around but not too much info that I found.
    Is it best just to use the front tube and drill x2 new holes, will the RHS cable pass under the Bimini support tubes to the LHS?
    Seems odd to have holes with grommets that go no where so perhaps one can enlighten me some.......
    Cheers BruceR, AUS Melb.
    Bruce
    2014 Moomba Mondo

  2. #2
    Join Date
    Oct 2008
    Location
    Central, Arkansas
    Posts
    830

    Default

    On the port side there is no predrilled hole on the upright tube. Why it was not done, since they did one on the starboard side for the darn light....urrrrrr

    Seems most have drilled a hole in the upright to jump over to the factory hole on the back tube. Then drill new holes for the speakers on the back tube, which is going to leave the factory open hole on the starboard side.

    I don't have any pictures, but I went the no wire show route after a buddy tested it. I took the grommet out of the factory port side hole and drilled back into the upright tube. My WS clamp covered the little wallowing that occurred at the grommet hole. I used WS wiring since I had the LED light rings on my speakers. This technique was used on 2 OZ and 1 OZHD towers.
    2014 Mojo Surf
    2013 Mojo Sold
    2010 LSV Sold
    2002 OB LSV Sold

  3. #3
    Join Date
    Jul 2015
    Location
    Melbourne, Australia
    Posts
    77

    Default

    Thanks Mcdye for the reply.
    Will try test fitting the clamps over the factory holes to see if all good and see if I get the courage to start drilling.
    Cheers BruceR, AUS Melb.
    Bruce
    2014 Moomba Mondo

  4. #4
    Join Date
    Feb 2006
    Location
    Birmingham
    Posts
    1,228

    Default

    I ran mine down the starboard tubes and then followed the wire loom that goes around the bow and over to the port side. I used the stock mounting holes in the corner to attach the speaker to the tower. They have been running that way for 2 years on a '15 Mondo and I have had no issues and I drilled no holes.
    15 Mondo Surf Edition

    02 LSV - Traded In

  5. #5
    Join Date
    Jul 2015
    Location
    Melbourne, Australia
    Posts
    77

    Default

    Thanks JesseC, will have another look and play over the weekend.
    Will trial fit clamps and poke some stiff wire up some tubes to see what works....or doesn't.
    I originally liked the idea of using the upper rack mount position/plate on the tower and doing away with the clamps but I'd have to drill thru the front tube to make a pass thru to the cross plate to get wires thru. Could be done but no going back if I stuff that up or change my mind!
    Cheers BruceR, AUS Melb.
    Bruce
    2014 Moomba Mondo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •