Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1
    Join Date
    Dec 2016
    Location
    Arkansas
    Posts
    18

    Default Blower not working, trips breaker when turned on

    Hey all, I searched but could not find anything addressing this.
    I have a 2012 Moomba Mojo 2.5 with 100 hours. The blower will not turn on and when the switch is turned on, it trips the fuse breaker. Does this mean I need to replace the fuse or does this mean I have a loose wire/failed blower?

    Thanks in advance.

    Bryan
    2012 Moomba Mojo 2.5
    Indmar Assault 333

  2. #2
    Join Date
    May 2013
    Location
    Lake Anna, VA
    Posts
    816

    Default

    Disconnect at the blower and turn it on again. If it doesn't trip you are looking at a new blower most likely. There is no load so it isn't a perfect answer but at least means you have no short before that point.
    2007 XLV Gravity Games
    Full Wake Makers upgraded ballast and pumps
    1,100 in each rear locker
    1,180 in front
    OJ 1435 prop, 325 EFI Indmar Assult.
    Fresh Air Exhaust
    SuckG8
    Bunch of other crap

  3. #3
    Join Date
    Mar 2003
    Location
    s.e. washington state
    Posts
    2,775

    Default

    If you find it is the blower, check inside the housing for debris that may have locked it up.
    1998 Mobius
    310 HP PCM

  4. #4
    Join Date
    Dec 2016
    Location
    Arkansas
    Posts
    18

    Default

    Quote Originally Posted by 5:00 View Post
    Disconnect at the blower and turn it on again. If it doesn't trip you are looking at a new blower most likely. There is no load so it isn't a perfect answer but at least means you have no short before that point.
    Sorry for the noob question but when I disconnect from the blower, I'm disconnecting one or two wires? Do I just leave them loose or connect them to complete the circuit?

    Thanks in advance.
    2012 Moomba Mojo 2.5
    Indmar Assault 333

  5. #5
    Join Date
    Apr 2017
    Location
    Hayden Id
    Posts
    180

    Default

    one wire would be enough to tell if it was the blower or not, if your breaker pops with one wire disconnected, the problem is downstream.
    2017 Craz surf auto wake
    1140 # rears wet sounds

  6. #6
    Join Date
    Dec 2016
    Location
    Arkansas
    Posts
    18

    Default

    Will do this weekend. If it does not trip, does that mean its battery side/fuse? If so, where can I order a fuse?

    Also, maybe related, maybe not, my depth gauge works but shows ---. Is this a transducer problem?

    Thanks for all the help!
    2012 Moomba Mojo 2.5
    Indmar Assault 333

  7. #7
    Join Date
    Nov 2003
    Location
    Land O Lakes, Florida
    Posts
    6,371

    Default

    replaced 3 blower motors on my 2013 LSV. water would get into the blower motor and rust it causing increased resistance causing the breaker to trip.

    simple replacement
    Hey, Its Moomba time

    Its all about the dash - enjoy the dash, as that is your time between the dates
    13 Mobius LSV-sold
    08 Mobius LSV-sold
    03 Mobius LSV-sold
    life is about finding the balance between being a responsible adult and staying young at heart

  8. #8
    Join Date
    Apr 2017
    Location
    Hayden Id
    Posts
    180

    Default

    If it does not trip with the blower wires disconnected, then it's the blower motor, chances are that is what it is, moombadaze is spot on with what usually happens. Not sure on your depth gauge, I see that same --- a lot ,every depth gauge that's been in 3 different new boats , the only time they seem to read is when sitting at an idle,
    2017 Craz surf auto wake
    1140 # rears wet sounds

  9. #9
    Join Date
    May 2013
    Location
    Lake Anna, VA
    Posts
    816

    Default

    My depth was off and on last year. I found the thru hull transducer had come unglued which is a common problem. Check for that. Not sure if yours is thru hull. I epoxied mine in again this season and it has been rock solid so far.
    Your breaker is probably fine most likely.
    2007 XLV Gravity Games
    Full Wake Makers upgraded ballast and pumps
    1,100 in each rear locker
    1,180 in front
    OJ 1435 prop, 325 EFI Indmar Assult.
    Fresh Air Exhaust
    SuckG8
    Bunch of other crap

  10. #10
    Join Date
    Dec 2016
    Location
    Arkansas
    Posts
    18

    Default

    Thanks a ton for the replies! Very helpful community here! We are heading up this weekend and I will take a look at both of these.

    I am having trouble finding a schematic of where the blower is. Can someone show me a pic or describe where it is in the engine?

    Thanks,
    2012 Moomba Mojo 2.5
    Indmar Assault 333

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •