Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19
  1. #11
    Join Date
    Oct 2008
    Location
    Central, Arkansas
    Posts
    847

    Default

    I would have to double check but I want to recall the replacements, the pin goes thru the bottom part as to sitting in a drilled groove.

  2. #12
    Join Date
    Oct 2013
    Location
    Gainesville, GA
    Posts
    118

    Default

    Atlanta Marine has ordered me replacements. I just sent in a couple of pictures and they got right on it. I am so impressed with SC and Atlanta Marine! Heidi has just been awesome to work with.
    Mark
    2014 Mondo
    2013 Yamaha AR190 - Gone...

  3. #13
    Join Date
    Mar 2014
    Location
    Orlando, FL
    Posts
    9

    Default

    I have a 14 Mojo and both racks have swiveled around and almost taken someone's head off.
    Good to see others are having this problem and it not just me, Guess I will take it to the shop and have them inspect and replace.

  4. #14
    Join Date
    Jun 2013
    Location
    rockwood tn
    Posts
    27

    Default

    my racks has chipped the paint on both sides where they turn into far and theres no way to adjust them i hate it everytime i see it! and they have been replaced with the new ones

  5. #15
    Join Date
    Aug 2015
    Location
    Mn
    Posts
    343

    Default

    This problem has not been entirely fixed. I have a 2015 mojo, had boards on the rack and driving about 20 miles an hour. The rack suddenly swiveled inwards and almost hit a passenger. Both side racks have done it.
    2020 Supra SL 400
    2015 Moomba Mojo(Sold)
    2018 Yamaha Waverunner(Just to fool around)
    2018 F150 Lariat
    sport edition, 3.5lt ecoboost

  6. #16
    Join Date
    May 2015
    Location
    Woodlands/Conroe, TX area
    Posts
    296

    Default

    ^^^^^^^^pos!
    2008 Moomba Outback DD resurrection

  7. #17

    Default

    that's rocks dude !

  8. #18
    Join Date
    Jul 2017
    Location
    Central Wisconsin
    Posts
    15

    Default

    Update on this issue for future use and reference:

    SC referred me to Skylon about this issue today. I talked to Robby there (extremely helpful) he told me to remove the knob, it is threaded onto the pin with lock tight and it needs to be heated to break the bond. He also told me he has a few updated parts left with a longer pin and knob to correct this problem. You have to drill the seat a little deeper so the new longer pin will engage further into the block. I'll post some photos here of the new stuff when it arrives. The inventory of these parts is almost gone so maybe some photos will help people understand and fix this issue later on down the road. So for about $50 in parts, I'm going to get my racks fixed.

    Joe
    2013 Mobius LSV
    -345 Surf-

  9. #19
    Join Date
    Jul 2017
    Location
    Central Wisconsin
    Posts
    15

    Default

    Here is what Skylon sent me.
    (2) knobs (same as original)
    (2) springs (I think they sent me springs that were too long. They wouldn't compress enough. I used the original springs and they were just fine.)
    (2) new locking pins with for more engagement.

    You have to drill out the hole the pin engages into to make it a through-hole. I used a 9/16" bit to be just slightly larger than the pin. Then all you do is replace the pin with the new longer one.

    Use Loctite blue when you thread the knob back onto the pin threads.

    Original Pin


    New Pin


    New Pin
    2013 Mobius LSV
    -345 Surf-

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •