View Full Version : no power to fuel pump

06-11-2009, 02:47 AM
I just took my 2006 outback with a 325 MPI out of storage and tried to start it. Turned over fine but did not fire. Checked for power at fuel pump got 0 volts. the pump does not make a sound at anytime during start up. When I put 12 volts straight to the pump it would pump. I checked for loose wireing and made sure the safty lanyard was working properly. What would be the next/most likely possible cause of no power to the fuel pump?

06-11-2009, 06:45 AM
Check all your fuses, since you do have a meter check the OHMs in the wires from there starting location to the pump, make sure you dont ahve a shorted wire.

I'm not sure if theres fuses for that but id check all the fuses under the dash of the boat.

After that if you dont find anything get a wire diagram to see how the ignition switch is wired to see at what point it powers up the fuel system. Its not going to be a hard fix, its the tracking it down that is going to be hardest i think.

06-11-2009, 08:57 AM
Also, I think the fuel pump will only pump when a signal is sent from the oil pressure switch as well. This switch is subject.

As far as the wiring goes, you might could get up with skiers choice or indmar and get a wiring diagram of the engine and related parts, this would greatly reduce looking around as you would know what color wires you are looking for and where they go.

I assume everything in your instrument cluster is working as normal?

You also said "turned over fine but did not fire". Are you saying that there was also no spark detected at the wires/coil?

06-12-2009, 12:53 AM
Thanks for the suggestions. I've checked everything and still have'nt solved it. I talked to the Dealership and they think they may have time to look at it tomorrow but no promise. We have had frost warnings up until a week ago so you can tell how short our ski season is here in northern Alberta. I am hopeing I don't miss half of it [ that is eaqul to 3 weeks] with the boat in the shop. thanks again and now I'll let the professionals look at it.

06-12-2009, 10:26 AM
Hi Guys. I took one last stab at it before taking it in this morning and found the problem. I took your advice that it should be simple to trace back other than the 20 purple wires in a 80 wire harness. It ended up being a wire had disconected in the 20 wire harnes connection. It was still inside the harness but as soon as I pulled on the purole wire it fell out. Gave it a quick connection and the fuel pump fired right up. God willing and weather permitting I will be on the water rippin it up tonight.
Thanks again. Doug

06-12-2009, 10:46 AM
Hooray! Have one of those cold Canadian ones for the guys on here.

06-12-2009, 01:32 PM
Always keep things simple.

I love it when a plan comes together.