View Full Version : speedo problems

08-14-2008, 10:34 PM
I have an 02' Outback and am having sporadic speedo problems. The boat sits on a lift so it's not being towed to the lake. Typically, when first going out on the weekend they're not working then anywhere from 5 minutes to 4 hours into the day they're "there"....both bounce up to speed at the same time.

I'm figuring it's either in the wiring at the speedos (looks like the previous owner did some adlib on the speedo wires behind the dash) or the pick-up. I plan on reconnecting/recrimping this weekend. If that doesn't do it I'm guessing the pick-up (center-hull paddle-wheel, btw) or the wiring between the pick-up and the speedos. With both acting the same I doubt it's the speedos, but maybe??

Is there a way to check that the pick-up is signaling properly (voltage, resistance)? Is there a check for the speedos themselves??

Thanks in advance.

08-15-2008, 09:49 AM
When the speedos are out do your other gauges work? The signals from the various sensors to all the gauges goes through a 'Controller' which apparently is notorious for extreme sensitivity to grounding.

I had similar problems when no gauges worked and they never came back. I replaced the controller (which had gotten water in it from the speedo lines) and things seemed to be great for a while. Now I get sporadic behavior. It works fine for days, then stops, and then comes back anywhere from 10 minutes to a couple days later. So now I carry a gps with me on the water. If they cut out just start using gps. Cheaper than a new controller.

08-15-2008, 12:12 PM
I have no other gauge problems when I lose the speedos (I mean 'cept the fuel gauge like just about everyone else).
You mentioned water from the speedo lines.....I'm assuming you have the rear pick-ups with the pitot tube? I have the center (or close to it) mounted paddle wheel which I think is electronic. I'm guessing there's a magnet in the paddles and that's what the pick-up...picks up??
Would the controller be located under the dash? I plan on being under there this weekend and will check the ground.
btw....I have used my gps to calibrate the speedos and even after cutting out they stay true.

08-16-2008, 10:20 AM
In my 99 Mobius, if you sit in the driver seat and put your feet straight out in front of you there is the 'firewall', bulkhead, or whatever you want to call it. The controller on my boat is on that vertical wall just above where your left foot would be.

Yes the 99 still uses pitot tubes....

08-16-2008, 03:10 PM
I am having the same problem, except mine went out and didn't come back.

I have a 2004 Moomba LSV, and both speedometers are not working. So far I have checked the paddle wheel, and it spins freely, i have also made sure no wires were loose on the back of the speedos. If there is a fuse I don't know where it is, and I can't figure out why both are not working. Any suggestions?

08-18-2008, 01:49 PM
I got back from the lake last night. I checked all of the under-dash connections and everything was in order (I was going to recrimp everything but all of the connections were good).

Benson....thanks. I'll check for the controller this coming weekend - didn't notice it when I was under there.

In another post someone mentioned turning the ignition to on for a few seconds before starting the boat (said something about giving the gauges a chance to reset). I tried this approach and the speedos were working fine this weekend (not to say that next weekend they'll be gone).

I'd like to hook-up a meter to the wires, pull the paddlewheel and spin it so see if there's a "signal" but I'm not sure if it's voltage, resistance and where in the circuit I should connect....if anyone has an idea I'd appreciate the input. Incidentally, another guy on the lake has an '02 Outback and he's had the same problems on and off and has just learned to live with it.