View Full Version : depth gauge not working?

05-19-2008, 03:51 PM
Put the boat in for the first time this year and noticed that the depth gauge not working , there is power and I can set the low and high levels on it but it will not tell me the depth any ideas what to check out first?

05-19-2008, 05:43 PM
Check to see if the sender has come loose or does not have a tight seal. I had mine in under warranty and they "reapoxied" it. It has since come loose again. I tried to reapply it again. I didn't get a great hold so now it works about half the time.

05-28-2008, 01:57 PM
I intended to reapply the sending unit last night to see if i could get a reading again. Upon inspection, it appears to be holding very well and looks like a good "seal". Seems like I have three options:

1. Take it to the dealer. (Want to avoid doing it for $'s but more for inconvenience of two trips and the unknown of when I will get it back)
2. Try to get the old one off, clean up and reapply (Wondering if I will do more harm than good)
3. Can I buy just the transducer? Seems like I could leave the old one where it is, cut the wire and apply the new one to the other side of the transmission where there is more room.

Is there something else that I should be trying? There is constant power to the gauge, it just registers the flat line --- at all times.

The steering has also stiffened up quite a bit over the winter. I greased the rudder zerk, but after reading through the posts it looks like I'm headed for a steering cable replacement. I'm no Jesse C, so that looks like a trip to the shop for me.

I also decided to pull the trigger on a tower for my 05 Outback LSV. I decided on the New Dimension tower and they talked me into installing it myself. When factoring in the cost of the tower, installation and sales tax, it is about an $1,250 dollar difference for what appears to be the exact same tower. I intend to install it on June 6. We'll see......