View Full Version : All gauges quit

04-29-2007, 12:51 AM
So I was all pupmed this morning. Got the boat started in the driveway. Then down to the landing. Fired right up and off I went. Noticed that I was not really hitting top end like I should have ....

Then I realized all of my gauges quit working and froze where they were at the time they quit.

All the accessory switches on the dash seem to worok right. Engine still starts and stays running. Horn works.

This is a 99 Mobius carb with 230 hours. Boat sat in garage all winter in Wisconsin. No obvious signs of mice anywhere.

I looked for a fuse but could not find any - just the breakers on the dash for the rocker switches. After a couple of hours some of the gauges returned to the normal position for 'Off'. So I though restarting might 'reset' them. No luck.

Any help greatly appreciated.


04-29-2007, 07:04 AM
When they all quit like that, sounds like the ground is loose. Not sure about yours, but on me '04 Outback there is a metal strip they all connect to.
Hope this helps

NH Moomba
04-29-2007, 11:06 AM
I would search this board for threads about the Medallion Controller that drives all the gauges. Somebody named gaugeman listed a fix that worked for me.


04-30-2007, 12:44 AM
if the two waterlines are not disconnected on winterizing water can freeeze in the pressure sensor then penetrate the mdc and fry it

04-30-2007, 07:41 PM
I am not where I can look at it right now. But if I understand you correctly the water lines go the MDC (this is the Medallion Controller refered to in previous posts, right?) I was wondering where the spedo lines went since they do not go to the gauges.

So if the MDC fails then all gauges will freeze in the position where they were at the time of failure?

This is very possible. Sadly I had an authorized Moomba dealer winterize. Maybe they should have thought of this?


NH Moomba
04-30-2007, 11:27 PM
The pressure sensors in the Medallion Instruments MDC 1600 controller should be disconnected when winterizing. These controllers are known to have issues besides this. Sometimes the problems come from voltage drop due to bad connections. Check the circuit board on the gauge cluster for a connector labeled "to gauges" first. On my 2000 Ouback LS, bypassing the + and - feeds to the connector fixed the problem.

The controller is essentially an Analog to Digital converter that interprets the analog data from the speedo tubes, engine sensors etc and then communicates to the gauges through a digital data bus. A new one costs about 300 bucks and supposedly fixes the problems.

05-01-2007, 01:14 AM
where they connect to the mdc may be leaking and the guages may be sporadic or not reading at all.........as was my case.........water entered the mdc....remove it and shake and you can hear.......hard to tell if dealer disconnected as they may have to let water drain then reconnectafter drainage........but why as not have this part of the summerization process.....anyways, i always disconnect the lines....good luck


05-02-2007, 12:44 AM
So my local dealer now tells me that they have to custom order the part. Meaning bring in the defective one and they can request that the manufacturer custom build one to match it. And that it may cost as much as $1000.

Does any of this sound right to anyone?

Does anyone have a dealer I might be able to contact who can be more helpful?


NH Moomba
05-02-2007, 11:17 PM
I would try to call Medallion directly:



05-03-2007, 01:02 AM
the mdc unit was like 250 from medalion direct and took 5 mins to install

05-03-2007, 01:13 AM
Thanks for the link. I Googled them but they did not show up in the first couple pages of my search. I have emailed them. We'll see if they contact me.

The actual link to the module looks like it might be this:

05-07-2007, 07:25 PM
Pulled the MDC 1600 this weekend and found water in the secondary speedo line. The controller was full of water as well. I talked to Medallion directly and they have a part on hand for about $212, a far cry from the $1000 the dealer thought it might be.

My only concern is if there is a leak in the speedo line it might allow water up the line again on the new one.

Anyone have a sure fire method for easily testing speedo lines for leaks?


NH Moomba
05-07-2007, 07:55 PM
The line probably isn't leaking but you should be able to pressurize it with gauge and a syringe or something and see if it leaks down after plugging the other end. More than likely the water was forced into the controller after freezing water cracked the pressure sensor on the MDC. It is similar to the older style gauges that used a diaphragm in the speedometer to indicate pressure/speed. When the diaphragm split, water would fill up the gauge and drip out. These days they use paddle wheels that give a nice digital signal - no more pressure devices.


05-08-2007, 02:27 AM
I tend to think you are right. The mfg rep agreed that it was probably water, but from condensation, not frmo the speedo line, that caused the initial leak in the presure cavity of the board. Then once there was a leak you get a path for the flow, instead of a pressurized cavity. So instead of air pressure on the transducer from water trying to find it's way up the line, you actually get water finding it's way up to the leak, i.e., the pressure cavity on the controller, and then - disaster.

Mfg recommends pulling the controller every winter and storing it inside - protecting from freezing.

Thanks for all your help.


05-12-2007, 07:56 AM

Where is this unit mounted in the boat?


05-14-2007, 12:30 AM
On my '99 Mobius the MDC 1600 is located on what you might consider the firewall (if you were in a car). It is the vertical bulkhead under the dash that you hit with your feet if you stretch out in the drivers seat. It is pretty much directly opposite the dash in the upper left hand corner. It is pretty much all black, about 6 inch by 9 inch and about an inch thick. It has a white lable with a model number on it, and a date code. Look for the two speedometer lines that lead to it. The unit has two speedo labels, Secondary and Primary that are readily visible where the speedo lines attach. The actual name, MDC 1600 is in raised letters, black on black.

The good news is that the new unit solved the problem. I spent a little extra time blowing the secondary line out (by mouth) to make sure nothing was still in the line. I still need to gps the speedos.

From now on my MDC will probably come out every winter and get stored inside.

So now we just need to wait for the weather to cooperate. We have had whitecaps almost all day long ever weekend...

05-29-2007, 09:43 AM
I'm new here....I can not locate this controller [2000 Outback LS]. It is possible I don't have one? All I see is the Mercruiser Keyless Ignition controller. Could that be the problem? If so, what next?

NH Moomba
05-29-2007, 03:24 PM
On the 2000 LS the controller is in the ski locker behind a carpeted panel. You need to take out the 2 screws and remove the panel to find it - very inconvenient to remove every season.

06-11-2007, 01:16 AM
So we are out on the lake today and suddenly the gauges go all dead - again. We skied by thumb for a while. Then when I throttled to full speed they started working again. Then idled down and they quit. Then raced up and down the lake and they worked.

Maybe the battery is going??


NH Moomba
06-11-2007, 05:07 PM
The problem is probably a bad ground. Search the site for a user named gaugeman and he talks about voltage drop from bad grounds to the controller. There is a PCB behind the gauges that has a connector labeled "to gauges" that feeds the MDC controller. There is one - and one + wire passing through the connector. You might be able to clean them up and solve the problem but better yet is to bypass the connector by picking up the extra + and - spade terminals on the PCB with a couple of Fast-On crimps and splicing into the harness. That way you can still unplug the connector and you just have to disconnect a couple Fast-Ons from the spade terminals.


06-27-2007, 03:08 AM
i too have been having this problem on my '01 malibu response lx.

i pulled the mdc-1600 and see that there is a super clean and dry secondary input but a dirty/yellow/wet primary input. water doesn't come flowing out of the box, but there is clearly moisture in it. is this normal?


07-19-2007, 07:26 PM
Does anyone have a wiring diagram for a 2000 outback mdc-1600 system?
It sounds like I could be having a ground or voltage issue and need to ID the right wires to check voltage.


04-05-2008, 12:35 AM
My guages have all frozen and it sounds like I need to replace the MDC 1600. I checked voltage on guages and ground and all seem to be fine. I took to a boat mechanic and wanted to rewire harness but doesnt look to be the issue which was a $125 to tell me the wrong fix! Had any one called Medaillion lately to see if you can still order the mdc direct or has anyone found a place to get one resonable?

04-05-2008, 07:44 AM
Benson, I know this sounds pehistoric but while driving boat when guages aint working just reach under dash and start wiggling wires to see if you get any action, I truly believe you just have a loose ground wire. Happened on my '98 mobius once and was my prob. you could do it in the drive way on a fake lake with some help watching guages while you lay under dash and start checking connections. I'm not sure I have this box they speak of tho. My speedos are pressure operated. Once had one filling with water took it all apart could not determine hole in diaphram(sp?) cut a little of end of rubber tube feed pushed snuggly back on walla no more water. wishing you a quick fix, bob

"if a blind hog roots long enuff he will find an acorn" :wink:

04-07-2008, 11:19 AM
Hey thanks for the advice. Does anyone have a schematic for the wiring. I believe it may be a grounding issue like you say. I have checked voltage on guages and all there and I even added a wire from the ground of the battery all the way over to the grounding block under the dash. I also replaced the mdc but not the fix...but have managed to drop $250 on a part that didn't fix problem.

04-14-2008, 12:51 PM
it's a loose ground wire

04-15-2008, 12:26 AM
Can anyone tell me what wire is the ground to the mdc. I have a strong feeling this is the issue.

04-15-2008, 07:55 PM
Hmmm I've never heard of this MDC thing before.....
Does the '99 Outback have one as well in the same location?
If so I guess I better check mine when I get her out of storage.


04-18-2008, 03:03 AM
srry to to be vague. just know i bought 2 wake plate gauges (long story) when it was just a matter of getting under the dash and re-affixed the green wire coming from the device and it worked. have no idea what all this mdc stuff is about. your problem sounds more complex but still sounds like a loose ground. imo think you are looking at the wrong problem. i am by no means a mechanic or expert. just a boat owner. i will always check grounds for my gauges first from now on. no one told me this and i couldn't find it anywhere.

example - just summerized my boat and have dual optimas charged at interstate battery and they're burning rotten sulfur - no threads anywhere but it looks like i have the only 2 bad optimas in the history of this board lol - what do you do ?

so i hope this helps. if i'm wrong i still hope you are able to get it resolved and get on the water w/ gauges intact. best wishes.

10-15-2009, 12:44 PM
Where is the MDC controller located? I have the same problems on a "99 Outback. None of the gauges work (except for the hour meter) and we tested power to the dash panel and its getting power. Thinking it could be a grounding problem or the MDC thing.

10-16-2009, 08:38 AM
Controller is a black box about 7x9 by 1 inch thick, mounted on the 'firewall' under the dash in the upper left hand corner. I bet your hour meter does not actually work. It probably displays, but does not gain any time. If you find your speedometer lines and follow them back to the dash, you should find that they don't go to the dash, but rather to controller. If you get the controller off and shake it - you will probably hear water....

10-16-2009, 09:54 AM
I will check this out this weekend and report back. The hour meter definately works.

03-16-2010, 12:24 AM
I will check this out this weekend and report back. The hour meter definately works.

Same thing here... 99 Outback with guages that don't work, but the hour meter is working and gaining time. However, my switches for ballast control and bilge etc etc etc. are also faulty. When they don't work you can hold the breaker down and they start working even though the breaker wasn't thrown. Seems like loose breaker panel. Is there a rewiring in my near future or is this all related to the MDC?