PDA

View Full Version : Swim platform mounting bolts leaking?



justflyinglow
09-18-2018, 07:39 AM
Hello all. I am new to the forum. I am considering buying a 2015 Moomba Mondo. There was a pre inspection done on the boat that states "Slight staining from leaks were found on the transom at the mounting bolts for the swim platform. These bolts should be monitored and repaired as needed." Is this common? Is this a major problem? I need to look at the boat again so I can take pictures. Thanks for the information and advice.

rdlangston13
09-18-2018, 07:46 AM
Never heard of this issue but I would think you could remove the swim platform brackets and apply some more 3M marine sealant and reinstall them to fix it maybe.


Sent from my iPhone using Tapatalk

dakota4ce
09-18-2018, 08:45 AM
Or just see in live wet conditions if they leak. If so, try to seal around them without removing. If that doesnít work, remove and reinstall.

Itís not a deal breaker by any means, and I would avoid removal if you can just to keep it solid.


Sent from my iPhone using Tapatalk

Jeepers
09-28-2018, 01:29 AM
Easy fix as others have mentioned. However, I would pull the swim platform brackets off and allow any moisture which may have been absorbed through the fiberglass to dry out over the winter and re-install in the spring with 3m 5200 fast cure.

Youíll probably need to use a heat gun to soften the existing 5200 that was used when the brackets were installed at the factory. Just donít burn your gel coat! [emoji23]

When you go to reinstall, squirt some 5200 in each bolt thru-hull and all over the back side of the bracket. Tighten it back up, being careful not to over tighten. Wipe off the 5200 that squishes out the sides with rubbing alcohol and youíre good to go! Although, it safe to throw it right in the water after the install. I always give the 5200 24-48 to cure.




Sent from my iPad using Tapatalk Pro