PDA

View Full Version : 2014 Outback V ballast bag leak



tyjennings
09-13-2016, 05:08 PM
The ballast bag in my ski locker slowly looses water, but the digital readout still shows the bag at 100%. I pulled the empty bag out and it appears to be in good shape with no visible tears or punctures. Any idea what would cause it to loose water? Do I have a bad valve or something somewhere? I'm pretty new to all of this.

mikenehrkorn
09-13-2016, 05:35 PM
Maybe check the fittings? And the 100% would never change because they just use timers to set the percentage, there is no actual water level reading.

MJHSupra
09-13-2016, 11:02 PM
The ballast bag in my ski locker slowly looses water, but the digital readout still shows the bag at 100%. I pulled the empty bag out and it appears to be in good shape with no visible tears or punctures. Any idea what would cause it to loose water? Do I have a bad valve or something somewhere? I'm pretty new to all of this.

Are you getting water in the boat once it's filled? As the previous post said, check the lines and fittings.

On my '07 I have a vent-line on the top of each bag. When the pumps are filling, I know the bag is full and the air is pushed out when water starts running out the vent line off the side of the boat. Thus 100%. I do not have times as many of the new boats do, but the plumbing works the same way.

gbh424
09-17-2016, 03:02 PM
As others said, check the fittings. I discovered a leak in one of my bags the other day as the floor was wet under the bag. Turns out the o-ring on the bag fitting got pinched at some point and was leaking by.


Sent from my iPad using Tapatalk

Ed_Geary
05-10-2017, 10:00 AM
my bags leak when it is time to replace the Jabsco impellers