PDA

View Full Version : Throttle/Perfect Pass issue??



blackcup
08-13-2014, 12:04 PM
Yesterday was out surfing and had PP set at 9.6. Everything is fine and then all of the sudden BAM the boat stops instantly. It was like someone just completely cut all power. I am surfing behind and realize what has happened and have to bail hard right to avoid hitting the back of the boat. Checked with the driver and throttle was still buried and he insists he didnt touch a thing. Still power to the boat. Just had to turn the key and it started right back up.

Very same thing happened to me the day before when I was on the back ... actually grazed the back corner of the boat.

Also happened again once before a few weeks ago when I was driving and my wife was on the back. It has only ever happened when surfing ...

Any idea what this could be??? It freaks you out a little knowing that at anytime the boat could stop and you have to be ready to bail. I'm just terrified that it will happen when we have someone up there who is just starting out and they smack their head off the back of the boat.

slipperyrockTKE300
08-13-2014, 01:00 PM
funny you mention this - same thing happened to me, but my engine didn't shut off - the boat just lost all forward speed.

My wife and brother in law (who was surfing at the time and made a grand entrance into the boat) blamed it on me.

I have the stargazer - wonder if it was some kind of satellite hick-up?

kaneboats
08-13-2014, 01:05 PM
I had the same thing the other day. Somehow I bumped the lanyard switch and had a momentary interruption.

mmandley
08-13-2014, 01:08 PM
Each time we had that happen it was bumping the lanyard.

It barley takes any contact and it will cut the power off instantly.

I found myself doing it once because sometimes I kick my feet back under the seat.

blackcup
08-13-2014, 06:43 PM
Hmmmmm Ok I will test it out when I am in the water next. Maybe it was the lanyard like you said ...

Spokanite6
08-21-2014, 10:32 AM
The linkage could be getting snagged on the engine cover or something else. I believe that will shut off everything.


Sent from my iPhone using Tapatalk

Ian Brantford
08-21-2014, 02:30 PM
Also check the electrical connections. On the model on my boat, they are not shielded against water, so corrosion or am intermittent short circuit could be an issue.