View Full Version : New MDC, now what?

06-14-2013, 09:32 PM
Could be a fluke, please feel free to give your advice. I just replaced my MDC and tach in my 2000 Outback LS and went to start it, wanted to see that new tach move! (and I wanted to see oil pressure activity on the gauge for the 1st time :o) Did my normal routine, prime the throttle twice to set the choke, bring it back to a little off idle, turn the key. It fired up for a second and then died when touching the throttle to keep it running. Tried again and kept firing then dying until nothing more than cranking now - no fire what so ever.

I found out at an earlier time i can get the battery + lead to touch the post on the solenoid that drives the fuel pump, so I did this for 5-10 seconds. Turned the key and it at least fired, but only for a second. Now I have done enough reading on this forum to jump all over my oil pressure switch, however, the last time out we had no problems at all... is there anything in a MDC that would contribute to the above problem? I swapped back to the old one for the heck of it and still no fire.

Assuming you guys all post back saying it's my oil switch, can these be sourced locally? (Napa, O'Rielly's, etc) and if so, any P/N suggestions? Trying to get out on the water tomorrow!

Last question then I'll hit post! Three wires coming off the switch, but the electrical diagram shows the switch as a normally open circuit with only one wire. Which ones do you jump to take the oil switch out of the circuit?

Thanks for the help guys, this forum is great!

06-17-2013, 01:48 PM

Looked all over town for a replacement "fuel pump protection switch" and the earliest anyone could have one was this morning - nixed that idea and decided if I had to I would jumper the switch out of the circuit.

Once back home I checked the float bowls in the carb. Front bowl was full, rear was empty. I jumper'd the pump and removed the needle valve assembly assuming the float was stuck closed. Still no fuel.

Crawled inside my rear locker and began taking out the pickup tube. Almost destroyed the checkvalve nipple since it decided after 13 years it did not want to come apart. Wasn't until after about 20 minutes of sweating, cussing, and movement stuck back in that locker that I realized I didn't hear any fuel sloshing around in the tank. None!

Put 11 gallons in by hand from my portable tanks and jumper'd the pump again and now we have fuel. Had to take apart the Holley carb to reset the float level but all is well again. I either ran it out of fuel PERFECTLY last time at the lake or someone decided an unlocked gas cap was a good way to get fuel...

At least I now know that my check valve is in perfect shape, the fuel hose has not collapsed due to ethanol damage, my fuel pump works fine, my oil pressure switch is good, and the fact I can fit in the rear locker. Silver lining to every problem I guess!