View Full Version : WakePlate Problem

10-03-2005, 04:05 PM
Howdy Everyone,

Just picked up my 05 Mobius LS Saturday! Love it. However on Sunday a couple of friends and I headed to the local lake and went out for some wakeboarding. Upon getting to the lake, I tilted the plate up so I could use the entire wake the boat produced (the level indicator shows up for bow up and down for bow down), with no problem. But when we wanted to move it down it would not function. I tried the wakeplate at the dealership on delivery day with no problems. Any suggestions? I would go back to the dealership, but it is a 2-hour drive from my house.

I did pop my head under the dash and followed the power line for the wakeplate and it was fine and connections were tight and the fuse was good. Also checked the actual plate and it was fine, no binding where the pivot point is.

Hope it is something simple.

10-03-2005, 04:43 PM
The pump in our 05 LSV went bad after dealer delivery also. Took it back in and they tapped on the side of the pump with a screw driver handle and it started to work again. They indicated that sometimes they get "froze up". Took the boat home and it quit working again, the dealer replaced the pump. Try to locate the pump and try what they did... might work for you???

10-03-2005, 05:53 PM
Found the pump (for those who are looking for it, if you unscrew the back cover, in the "truck" section of the LS, and take it off, you will see it almost dead center with the reservoir below and the pump on top). I tapped it with a screw driver a few times with no change, but not sure if the boat needs to be running in order to move the wakeplate.

I am heading out tomorrow after work and will let you all know if this fixes it. If not I will probably wait until my 20 hr seeing as it is stuck in the wakeboard position and won't have much negative impact on me having fun. If there are any other suggestions, let me know so I can try them out tomorrow.

Thanks for the quick reply!


10-03-2005, 07:23 PM
Also check the fluid level in the resevoir. Mine had a leak and ran out of fluid after a few hours of use. Once I refilled the resevoir, wakeplate worked fine. Good luck.

10-03-2005, 10:26 PM
Thanks for the tip sawbones. I looked in the reservoir and although I could not tell for sure, it looked to be at the full line. I'll keep you all informed on what I find out.