View Full Version : 04 moomba xlv speedo not working but paddle wheel spinning

03-10-2012, 02:28 PM
Hey guys were out on the lake and we don't have speed. The dash was replaced and before that, it worked fine. Any idea why it would stop working? Everything has been connected the exact same way as when we took it off. We are clueless so any help is appreciated.


03-11-2012, 09:29 AM
Several of us have had a similar problem before. I have a 2005 Outback and for me it was caused by the main connector coming off the paddle wheel being too low in the bilge. Once I disconnected the Speedo from the paddle wheel cleaned out the connection and zip tied the connector higher up never had another problem.

03-12-2012, 07:00 PM
Did you guys find the problem yet?

03-15-2012, 12:38 AM
Did you guys find the problem yet?
Haven't had time to look back into it yet. I replaced the dash panel, replaced all the gauges, did an oil change, trans flush, and took it out sat. We didn't discover the prob until we where on the water. The paddle wheel spins, everything is hooked up, and I checked the connection down by the bilge. Never found anything. Luckily I was able to set the perfect pass to run off the rpm so we could still board cause the speed on the perfect pass gauge didn't work either. Worked out rather well. But I pulled the boat out sat night and went straight down to panama city. Just got back tonight. Hopefully I'll have some time to look into it this weekend. I'll post the fix as soon as I can figure it out. Anybody else have any suggestions before I jump back into it?

03-18-2012, 01:32 PM
So I looked into it more today before I head up to the lake. Did an ohms test from the paddle wheel to the gauges. No shorts, all the wiring is fine. I found a post on the Internet on how to test the paddle wheel itself. Come to find out thats my problem. When i was hooking up the new gauges i accidentally hooked on of the plugs up wrong and popped a breaker. Im guessing thats what shorted the paddle wheel. Looking at around $150 for a new one. Might just switch to the updated perfect pass that reads off gps speed. Here's the post I found incase anybody else has this problem and needs to test it there's:
I found out my paddle wheel speed sensor failed. Here are the steps that the nice folks at Perfect Pass walked me through to find that it was truly failed.

Leaving the paddle wheel plugged into the PP Black Box turn on the key.

Using a pin and volt ohm meter (12 v dc). Check voltage on the red wire by using the pin on the back side of the paddle wheel input wiring clip. You need the pin because you will not be able to get your meter leads into the back of that really small wire harness connection. Should see some where between 11 and 13 volts.

Now place the pin on the next wire up which is the green wire. The green wire is the speed sensor wire. Using an alligator clip put your test lead and pin on the green wire so that your hands are free.

Pull your paddle wheel out of the hull by removing the holding pin. Easy to do.

Watching the voltage, rotate the paddle wheel 90 degrees. You should see the voltage change from either 12 volts to 0 volts or vice versa. Rotate another 90 degrees and the opposite should happen.

If you paddle wheel is failed like mine was, you will have 10.6 volts and as you rotate the paddle slowly, there is no change in that voltage.

At this point either the sensor itself has failed, or the wire between the sensor and the perfect pass is broke. Being very small gauge wire this is very possible. To make sure that it is not simple a bad wire, cut the wires about a foot or so from the paddle wheel. Strip them back.

Put the white wire to Ground -, Red Wire to 12 volts +, and then do the same test on the green wire. If the voltage pulses and the paddle wheel is working, your wire is bad. You could splice a new wire from that point back to the black box. If the voltage does not pulse then you definetly know the paddle wheel is bad. There is magnets and a printed circuit board in that paddle wheel. The circuit board must have failed.

03-19-2012, 07:30 PM
I had the same problem as you and my paddle wheel was the problem as well. I decided to try the Nautic Laugic GPS unit that took me about 20 minutes to install. We are going to be testing it out this weekend and I will let you know how it goes. It was under $300. It seemed worth it to me to spend a little extra to get GPS.